What is procedure to configure Mirror rootvg in HP-UX?

Answer Posted / raghav

Perform Disk scan
#ioscan -funC disk
and choose the disk that is similar or bigger than the
primary disk partition
Create a physical bootable disk
#pvcreate -B /dev/rdsk/c0t3d0 (example)
Extend the primary vg [generally vg00]
#vgextend /dev/vg00 /dev/dsk/c0t3d0
Define configuration in boot LIF
#mkboot /dev/rdsk/c0t3d0
#mkboot -a "hpux -lq" /dev/rdsk/c0t3d0 --> to disable
Quorum
Mirror all LV to new disk
#vgdisplay -v vg00 |grep "LV Name" |awk '{print $NF}'
|while read line
>do
>lvextend -m 1$line /dev/dsk/c0t3d0
>done
Re-establish the location of boot, root, swap and dump
#lvlnboot -r /dev/vg00/lvol3
#lvlnboot -b /dev/vg00/lvol1
#lvlnboot -s /dev/vg00/lvol2
#lvlnboot -d /dev/vg00/lvol2
Add boot disk into file to ensure that when software is
installed the content of boot LIF of both disk will be
updated.
#vi /stand/bootconf
1 /dev/dsk/c0t3d0
:wq!
Hope this Helps you

Is This Answer Correct ?    2 Yes 0 No



Post New Answer       View All Answers


Please Help Members By Posting Answers For Below Questions

How to log out in unix?

531


What is a filter in unix? Give an example.

539


What are special characters in unix?

479


What are the entities that are swapped out of the main memory while swapping the process out of the main memory?

548


Why unix is secure than windows?

553






How do you change directories in unix?

522


What are the main features of korn shell?

523


What are unix options?

487


What is unix operating system and its features?

522


What is piping?

540


What is grep family in unix?

513


What is difference between unix and windows?

491


Why unix terminals are called dummy terminals?

550


How do I search for a file in unix?

515


What is unix operating system explain various components of unix operating system?

482