What is procedure to configure Mirror rootvg in HP-UX?

Answers were Sorted based on User's Feedback



What is procedure to configure Mirror rootvg in HP-UX?..

Answer / raghav

Perform Disk scan
#ioscan -funC disk
and choose the disk that is similar or bigger than the
primary disk partition
Create a physical bootable disk
#pvcreate -B /dev/rdsk/c0t3d0 (example)
Extend the primary vg [generally vg00]
#vgextend /dev/vg00 /dev/dsk/c0t3d0
Define configuration in boot LIF
#mkboot /dev/rdsk/c0t3d0
#mkboot -a "hpux -lq" /dev/rdsk/c0t3d0 --> to disable
Quorum
Mirror all LV to new disk
#vgdisplay -v vg00 |grep "LV Name" |awk '{print $NF}'
|while read line
>do
>lvextend -m 1$line /dev/dsk/c0t3d0
>done
Re-establish the location of boot, root, swap and dump
#lvlnboot -r /dev/vg00/lvol3
#lvlnboot -b /dev/vg00/lvol1
#lvlnboot -s /dev/vg00/lvol2
#lvlnboot -d /dev/vg00/lvol2
Add boot disk into file to ensure that when software is
installed the content of boot LIF of both disk will be
updated.
#vi /stand/bootconf
1 /dev/dsk/c0t3d0
:wq!
Hope this Helps you

Is This Answer Correct ?    2 Yes 0 No

What is procedure to configure Mirror rootvg in HP-UX?..

Answer / srinu babu

1. step is create the BDRA(Boot disk Reserved area)on a disk to be used as a mirrored of the boot-able disk.
#pvcreate -fB /dev/rdsk/c2t6d0
Created an LVM header with a BDRA
#vgextend vg00 /dev/dsk/c2t6d0
Include the disk into vg00
#mkboot /dev/dsk/c2t6d0
Created a LIF on the new disk and add the LIF Filesystem to the BDRA
#lvextend -m 1 /dev/vg00/lvol1 /dev/dsk/c2t6d0
#lvextend -m 1 /dev/vg00/lvol2 /dev/dsk/c2t6d0
#lvextend -m 1 /dev/vg00/lvol3 /dev/dsk/c2t6d0
.
.
.
.
etc
#lvlnboot -R /dev/vg00
Ensure BDRA is synchronized
#lvlnboot -v /dev/vg00
#mkboot -a "hpux" -lq /dev/rdsk/c2t6d0

Is This Answer Correct ?    0 Yes 0 No

Post New Answer

More Unix General Interview Questions

What are the features and benefits of unix?

0 Answers  


Is android unix based?

0 Answers  


what is wrong with this interactive shell script?

0 Answers  


What is .login file in unix?

0 Answers  


How to copy files from one directory to other in unix?

0 Answers  






What is buffer header unix?

0 Answers  


"ls" command is showing all the subdirectoary and files which are present in the current directoary, i want to cut only directoary name. How to cut only name ?

2 Answers   Cap Gemini,


What is $# in unix?

0 Answers  


What are the general Commands in using Unix OS for a beginner? how many commands you know in that?

2 Answers  


How would you explain a kernel to a non-technical person?

0 Answers  


For which kind of fault the page is checked first?

0 Answers  


How to change the directory in unix?

0 Answers  


Categories